View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000042OpenFOAM[All Projects] Bugpublic2010-09-20 13:122010-10-11 21:59
ReporterBastiL 
Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformLinuxOSSLED 10 SP1OS Version10 SP1
Product Version1.7.x 
Target VersionFixed in Version 
Summary0000042: porousSimpleFoam does not generate the expected pressure drop
DescriptionThe attached testcase for porousSimpleFoam from 1.7.x does not give me the expected total pressure drop. Due to Darcy I expect to get:
deltaP= (mu * D * v + 0.5 * rho * F * v^2) * L
with: rho=1, mu=nu=1.4607e-5, v=5, D=3.7e7, F=222, L=4.2e-3 I expect:
deltaP,expected = 230.04 Pa

My porousSimpleFoam-Case gives me something around 195 Pa. This is not the expected result.
Steps To ReproduceRun the attached Case with porousSimpleFoam from 1.7.x and postprocess the total pressure difference on the two cyclic BCs "interior_porosity_in" and "interior_porosity_out".

NB: The testcase is to large to upload here.
TagsModelling, Solver
Attached Filestgz file icon porosity.tgz [^] (100,294 bytes) 2010-09-21 09:38

- Relationships

-  Notes
(0000043)
henry (manager)
2010-09-20 13:59

> NB: The testcase is to large to upload here.

Is it available from somewhere else?
Why is it so large?
(0000045)
BastiL (reporter)
2010-09-20 21:15

Not at the moment, sorry. I can send it by email if you like (11 MB). It has about 300k cells because it was initially intended for something else. I will try generating a smaller one.
The problem should in no way be connected to the size of the case.
Is the way I calculate the expected pressure drop correct?
(0000047)
BastiL (reporter)
2010-09-21 09:39

Henry,

here is a smaller example that demonstrates the same effect. The 0-Directory contains an initialised solution which you can use to run porousSimpleFoam on, the un-initialised BCs are in the 0_save-directory.

Regards Bastian
(0000057)
henry (manager)
2010-09-30 15:22

We have run several tests to study the issue you have raised. What we find is when running with the explicit handling of the porous media we get an overall pressure drop of 230Pa as expected but with the implicit approach it is 215Pa.

The pressure difference between the two cyclic BCs is indeed slightly lower than the overall pressure difference because a small amount of the porous media pressure drop extends into the neighbouring cells due to the centred interpolation practice used for 1/A in the pressure equation. If you include the layer of cells adjacent to each of the cyclic BCs when calculating the pressure drop you should obtain the correct result.
(0000061)
BastiL (reporter)
2010-10-04 09:47

Thanks for this explanation. But why do we have a difference of 15Pa (6.5%) between the explicit and the implicit approach? I did not expect this behavior.
We use implicit as our method of choice since we use quite large porosity values. I am not sure if we can use explicit but we need to do it to get the pressure drop we want.

Regards Bastian
(0000062)
henry (manager)
2010-10-04 09:58

Does the difference reduce when you refine the mesh?
(0000066)
BastiL (reporter)
2010-10-05 09:41

Yes, refining the mesh reduces the differences.
(0000067)
henry (manager)
2010-10-05 13:22

Further testing has shown that the difference between the results is caused by non-convergence induced by the use of a gradient limiter on the pressure gradient -- we would recommend against limiting the pressure gradient.
(0000068)
BastiL (reporter)
2010-10-05 21:47

Thanks once more, Henry. These schemes where taken from a more complex case (with quite a poor mesh). I guess this mesh needs the limiter. Which setting in fvSchemes are you exactly refering to an what is your recommendation for it? Thanks.

Regards Bastian

- Issue History
Date Modified Username Field Change
2010-09-20 13:12 BastiL New Issue
2010-09-20 13:59 henry Note Added: 0000043
2010-09-20 21:15 BastiL Note Added: 0000045
2010-09-21 09:38 BastiL File Added: porosity.tgz
2010-09-21 09:39 BastiL Note Added: 0000047
2010-09-30 15:03 henry Assigned To => henry
2010-09-30 15:03 henry Status new => assigned
2010-09-30 15:22 henry Note Added: 0000057
2010-09-30 15:22 henry Status assigned => resolved
2010-09-30 15:22 henry Resolution open => fixed
2010-10-04 09:47 BastiL Note Added: 0000061
2010-10-04 09:47 BastiL Status resolved => feedback
2010-10-04 09:47 BastiL Resolution fixed => reopened
2010-10-04 09:58 henry Note Added: 0000062
2010-10-05 09:41 BastiL Note Added: 0000066
2010-10-05 09:41 BastiL Status feedback => assigned
2010-10-05 13:22 henry Note Added: 0000067
2010-10-05 21:47 BastiL Note Added: 0000068
2010-10-07 18:00 andy Tag Attached: Modelling
2010-10-07 18:00 andy Tag Attached: Solver
2010-10-11 21:59 henry Status assigned => closed
2010-10-11 21:59 henry Resolution reopened => no change required