Close

21st December 2018

OpenFOAM & ParaView 5.6

ParaView 5.6.0 has been packaged Ubuntu Linux with the official reader module for OpenFOAM data with the package name paraviewopenfoam56.  Version 5.6.0 uses rendering code written to OpenGL API version 2.1, replacing v5.4.0 using legacy OpenGL.  The build includes  Mesa with LLVM/Gallium acceleration, which provides software rendering for systems without a graphics card (or supported graphics card).  The paraviewopenfoam56 pack has been released, along with updates to the openfoam-dev and openfoam6 packs, for the following versions of Ubuntu Linux, 64 bit:

  • 18.04 LTS, codename bionic
  • 18.10, codename cosmic

Installing ParaView 5.6.0

ParaView 5.6.0 is installed by upgrading an existing openfoam6 or openfoam-dev pack.  For example, to update openfoam6, simply open a terminal and enter the following commands:

sudo apt-get update
sudo apt-get install --only-upgrade openfoam6

Otherwise, ParaView 5.6.0 comes as standard with a new installation of the openfoam6 or openfoam-dev packs for Ubuntu 18.04LTS and 18.10 as described in Download v6 | Ubuntu.